2016
06.26

This blog is mainly about security but I will add a drone section. The first post is related to my painful and regretful purchased of a Xiro Xplorer V few months ago. Everything went fine at the beginning but not for long…

Read More >>

2017
03.25

This Metasploit module exploits an command injection vulnerability in Logsign. By exploiting this vulnerability, unauthenticated users can execute arbitrary code under the root user. Logsign has a publicly accessible endpoint. That endpoint takes a user input and then use it during operating system command execution without proper validation. This Metasploit module was tested against 4.4.2 and 4.4.137 versions.

more details here.

2017
03.25

LastPass had an issue with websiteConnector.js content script allows proxying internal RPC commands. The fix appears to not work on FireFox.

more details here.

2017
03.25

LastPass Domain Design Flaw

The LastPass domain regex does not handle data and other pseudo-url schemes.

more details here.

2017
03.25

The NETGEAR WNR2000 router has a buffer overflow vulnerability in the hidden_lang_avi parameter. In order to exploit it, it is necessary to guess the value of a certain timestamp which is in the configuration of the router. An authenticated attacker can simply fetch this from a page, but an unauthenticated attacker has to brute force it. Brute-forcing the timestamp token might take a few minutes, a few hours, or days, but it is guaranteed that it can be brute-forced. This Metasploit module implements both modes, and it works very reliably. It has been tested with the WNR2000v5, firmware versions 1.0.0.34 and 1.0.0.18. It should also work with hardware revisions v4 and v3, but this has not been tested – with these routers it might be necessary to adjust the LibcBase variable as well as the gadget addresses.

more details here.

2017
03.25

Gr8 Gallery Script suffers from a remote SQL injection vulnerability.

more details here.

2017
03.25

Gr8 Tutorial Script suffers from a remote SQL injection vulnerability.

more details here.

2017
03.25

wifirxpower suffers from local stack-based buffer overflow vulnerability.

more details here.

2017
03.25

EON 5.0 Remote Code Execution

EON versions 5.0 and below suffer from a remote code execution vulnerability.

more details here.

2017
03.25

EON 5.0 SQL Injection

EON versions 5.0 and below suffer from a remote SQL injection vulnerability.

more details here.

2017
03.25

Nuxeo Platform versions 6.0 (LTS 2014), 7.1, 7.2, and 7.3 suffer from a remote shell upload vulnerability.

more details here.